System Requirements

TexMaths requires the following softwares to be installed on your system:

TexMaths in action

In the above list, only one of the dvipng or dvisvgm programs is mandatory. To use the xelatex compiler, dvisvgm version 1.10 or above is required.


Installation on Windows

  1. Install a basic MikTex.
  2. The programs dvipng.exe, dvisvgm.exe and xelatex.exe are included in the MikTex package.
  3. Open LibreOffice Writer and install the TexMaths extension using the Tools / Extension manager menu. If asked, select the "Only for me" option.
  4. Close and reopen LibreOffice Writer. You will see the new TexMaths toolbar.
  5. Click on the TexMaths Equations icon and type your first equation. If something gets wrong, check the external program paths in the Sysconfig dialog.

Installation on Linux

  1. Install TexLive (on Debian based systems : sudo apt-get install texlive).
  2. The programs dvipng and dvisvgm are included in the texlive-binaries package. Eventually, install the texlive-xetex package for XeLaTeX support.
  3. Open LibreOffice Writer and install the TexMaths extension for the current user using the Tools / Extension manager menu.
  4. Close and reopen LibreOffice Writer. You will see the new TexMaths toolbar.
  5. Click on the TexMaths Equations icon and type your first equation. If something gets wrong, check the external program paths in the Sysconfig dialog.

Installation on Mac OS X

  1. Install MacTex 2017.
  2. The programs dvipng, dvisvgm and xelatex are included in the default MacTex 2017 package.
  3. Open LibreOffice Writer and install the TexMaths extension for the current user using the Tools / Extension manager menu.
  4. Close and reopen LibreOffice Writer. You will see the new TexMaths toolbar.
  5. Click on the TexMaths Equations icon and type your first equation. If something gets wrong, check the external program paths in the Sysconfig dialog.
Copyright 2012-2018 Roland Baudin